Как сравнить столбцы в Excel на совпадения

Как сравнить значения в двух столбцах таблицы excel и найти повторяющиеся.

Способ 1. Использование простой формулы

Данный способ сравнения подходит для столбцов любой длинны.

Алгоритм:

  1. Столбцы для сравнения располагаются на одном листе Excel (не обязательно, чтоб они находились рядом).
  2. Вписываем формулу =ЕСЛИ(A2=B2;”Совпадают”;”Не совпадают”). Где, А2 и В2 – адрес ячейки.
  3. Еще одна формула =ЕСЛИ(A2<>B2; “Не совпадают”;”Совпадают”).Где, А2 и В2 – адрес ячейки.
  4. Перетаскиваем ее вниз, до конца столбика.

Видеоинструкция: Как сравнить столбцы в Excel на совпадения с помощью формулы.

 

Способ 2. Использование макроса Visual Basic

Макросы – программные алгоритмы действий, записанные пользователем.

Сам макрос выглядит следующим образом и сравнивает столбец А со столбцом В. В столбцах может быть неограниченное количество заполненных ячеек.

Макрос:

Sub Sravnenie()

‘название указано выше, оно должно быть одинаковым, иначе программа не будет работать

Dim PosStr As Long

Dim FormStr As Long

PosStr = Cells(1, 1).CurrentRegion.Rows.Count

ActiveSheet.Cells(PosStr, 3).Select

ActiveCell.FormulaR1C1 = “=IF(RC[-2]=RC[-1],””Совпадают””,””Не совпадают””)”

Selection.AutoFill Destination:=Range(Cells(1, 3), Cells(PosStr, 3)), Type:=xlFillDefault

End Sub

Способ 3: Условное форматирование

Способ Условного форматирования основывается на создании пользователем правила, а затем уже сравнения 2 столбцов за правилом. В данном случае мы будем окрашивать ячейки второго столбика в цвета в зависимости от совпадения, или несовпадения данных.

  1. Выделяем данные столбца В и выбираем Условное форматирование.
  2. Создаем правило.
  3. Настраиваем правило и выбираем для сравнения ячейку А2. Обратите внимание, что программа Excel по умолчанию вписывает для сравнения не =$A2, а =$A$2. Если оставить формулу в таком виде, то все ячейки столбца В будут сравнивать с ячейкой А2.

Читайте также на нашем сайте:  Краткая инструкция как в Excel возвести число в степень и извлечь корень из числа
Оцените статью
( Пока оценок нет )
Поделиться с друзьями
Пошаговые инструкции по решению проблем с ОС Windows, Android, IOS